Wordpress : Résoudre le problème "LayerSlider: old jQuery issue"

Résoudre le problème « LayerSlider: old jQuery issue » 2

Résoudre le problème

J’ai récemment rencontré un problème sur un thème wordpress acheté sur thèmeforest avec le slider « LayerSlider » et une mise à jour WordPress, je vous laisse admirer le résultat :

Layerslider problem

It looks like you are using an old version (1.10.2) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer…

Le problème étant que LayerSlider ne prend pas en compte les versions de jQuery supérieure à « 1.9 ». Pour ce script, la version jQuery 1.10 revient à la même chose que 1.1 . Au final, il faut soit changer le LayerSlider s’il a été mis à jour par les développeurs (ce qui n’est pas le cas sans mon cas de figure), soit changer la version jQuery.

Si vous rencontrez ce problème, deux solutions simples s’offrent à vous. :

  • Il est bien évidemment possible, pour les développeurs uniquement, de supprimer l’appel à la version jQuery par défaut avec un wp_deregister_script(), et  un wp_register_script() avec une version plus ancienne (ou plus récente) de jQuery.
  • Encore plus simple pour les non-développeurs : un plugin WordPress  nommé jQuery Updater qui mets à jour votre version jQuery .

2 thoughts on “Résoudre le problème « LayerSlider: old jQuery issue »

  1. Répondre imprimante 3d fonctionnement Août 11,2013 11 h 41 min

    Merci pour l’astuce j’avais rencontré ce problème pour mon site et je l’ai vite résolu en téléchargeant le plugin jQuery.

  2. Répondre Christelle Alcazar Juin 6,2014 15 h 39 min

    Merci pour l’info. J’ai enfin pu résoudre mon problème d’affichage du slider sur le site d’un client avec le plugin Jquery updater!! Thanks 😉

Laisser une réponse